<!--M#s0--><!doctype html><html lang="en-us" dir="ltr"><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><script src="https://polyfill.io/v3/polyfill.min.js?flags=gated&amp;features=es6%2Ces7%2Cfetch%2CPromise.prototype.finally"></script><script src="/dist/js/index.b9892d1d.js"></script><link rel="stylesheet" href="/dist/css/index.4ffa9d9c.css"><!--F#7--><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><script>var googletag = googletag || {}; googletag.cmd = googletag.cmd || [];</script><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-M3QH8WQ');</script><script>
      (function (i, s, o, g, r, a, m) {
        i['FortnightObject'] = r; i[r] = i[r] || function () {
          (i[r].q = i[r].q || []).push(arguments)
        }, a = s.createElement(o),
        m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; a.crossOrigin = 'anonymous'; m.parentNode.insertBefore(a, m)
      })(window, document, 'script', 'https://d24bnj4f1s1f8m.cloudfront.net/1.0.0-rc.4.3/fortnight.min.js', 'fortnight');
      fortnight('init', { domain: 'https://indm.native-x.io' });
    </script><!--F#9--><!--F#2--><!--F#1--><!--F#3--><title>RS Components Named Top Distributor &amp; Educational Supporter at 2019 Elektra Awards | Industrial Distribution</title><meta name="description" property="og:description" item-prop="description" content="The electrical distributor has been recognized for its support of programs like FIRST Lego League and the STEM teaching resources it provides for teachers."><link rel="canonical" href="https://www.inddist.com/awards/news/21107068/rs-components-named-top-distributor-educational-supporter-at-2019-elektra-awards"><meta property="og:title" item-prop="name" content="RS Components Named Top Distributor &amp; Educational Supporter at 2019 Elektra Awards"><meta name="image" property="og:image" item-prop="image" content="https://img.inddist.com/files/base/indm/all/image/2019/12/16x9/rs_logo.5dfa86b2c92a1.png?auto=format&amp;fit=max&amp;w=1200"><!--F#0--><meta property="og:url" content="https://www.inddist.com/awards/news/21107068/rs-components-named-top-distributor-educational-supporter-at-2019-elektra-awards"><!--F/--><meta property="og:site_name" content="Industrial Distribution"><meta property="og:locale" content="en"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="RS Components Named Top Distributor &amp; Educational Supporter at 2019 Elektra Awards"><meta name="twitter:description" content="The electrical distributor has been recognized for its support of programs like FIRST Lego League and the STEM teaching resources it provides for teachers."><meta name="twitter:image:src" content="https://img.inddist.com/files/base/indm/all/image/2019/12/16x9/rs_logo.5dfa86b2c92a1.png?auto=format&amp;fit=max&amp;w=1200"><meta property="og:type" content="article"><meta property="article:published_time" content="Dec 18th, 2019"><meta property="article:modified_time" content="Dec 19th, 2019"><!--F/--><!--F/--><!--F/--><!--F#3--><!--F#2--><!--F#1--><!--F#3--><!--F#1--><script>dataLayer.push({"page_type":"content","canonical_path":"/awards/news/21107068/rs-components-named-top-distributor-educational-supporter-at-2019-elektra-awards","content":{"id":21107068,"type":"news","name":"RS Components Named Top Distributor & Educational Supporter at 2019 Elektra Awards","published":"2019-12-18T20:08:00.000Z"},"created_by":{"id":"5da9e4a26ab817ba319ed4a8","username":"mhockett","firstName":"Mike","lastName":"Hockett"},"company":{},"section":{"id":63212,"name":"Awards","alias":"awards","fullName":"Awards"},"section_hierarchy":[{"id":63212,"name":"Awards","alias":"awards"}],"taxonomy":[{"id":3142208,"type":"Tag","name":"rs components","fullName":"Tag: rs components (3142208)"}],"authors":[]});</script><!--F/--><!--F/--><!--F/--><!--F/--><script>googletag.cmd.push(function() { googletag.pubads().setTargeting('cont_id', ["21107068"]).setTargeting('cont_type', ["news"]); });</script><!--F#2--><!--F#1--><script>googletag.cmd.push(function() { googletag.defineSlot('/137873098/INDT/default_lb1', [[970,90],[970,66],[728,90],[320,50],[300,50],[300,100]], 'gpt-ad-lb1').defineSizeMapping(googletag.sizeMapping().addSize([980,0], [[970,90],[970,66],[728,90]]).addSize([750,0], [728,90]).addSize([320,0], [[300,50],[320,50],[300,100]]).build()).addService(googletag.pubads()); googletag.defineSlot('/137873098/INDT/default_rail1', [[300,250],[300,600]], 'gpt-ad-rail1').addService(googletag.pubads()); googletag.defineSlot('/137873098/INDT/default_rail2', [[300,250],[300,600]], 'gpt-ad-rail2').addService(googletag.pubads()); googletag.defineSlot('/137873098/INDT/default_billboard', [970,250], 'gpt-ad-billboard').addService(googletag.pubads()); });</script><!--F/--><!--F/--><!--F/--><!--F/--><script>dataLayer.push({"gtm.start":1576775627741,"event":"gtm.js"});</script><script>googletag.cmd.push(function() { googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.pubads().setTargeting('env', ["production"]).setTargeting('path', ["/awards/news/21107068/rs-components-named-top-distributor-educational-supporter-at-2019-elektra-awards"]).setTargeting('host', ["www|inddist|com"]); googletag.enableServices(); });</script><!--F/--></head><body><!--F#9--><div id="vue-1576775627741-530"><script>CMSBrowserComponents.loadComponent('#vue-1576775627741-530', 'RevealAdListener', {});</script></div><div id="vue-1576775627741-406"><script>CMSBrowserComponents.loadComponent('#vue-1576775627741-406', 'GTMTrackLoadMore', {});</script></div><header class="site-header"><!--F#1--><nav class="site-navbar site-navbar--secondary"><!--F#1--><div class="site-navbar__container"><!--F#1--><!--F#2--><div id="vue-1576775627741-403"><script>CMSBrowserComponents.loadComponent('#vue-1576775627741-403', 'DefaultThemeMenuToggleButton', {"className":"site-navbar__toggler","targets":[".site-menu"],"toggleClass":"site-menu--open","iconModifiers":["lg"]});</script></div><a href="/" class="site-navbar__brand"><!--F#1--><!--F#1--><img class="site-navbar__logo" alt="Industrial Distribution" src="https://base.imgix.net/files/base/indm/id/static/id_logo.png?h=40" srcset="https://base.imgix.net/files/base/indm/id/static/id_logo.png?h=80 2x"><!--F/--><!--F/--></a><ul class="site-navbar__items site-navbar__items--secondary"><!--F#1--><li class="site-navbar__item"><!--F#1--><a href="https://ien.wufoo.com/forms/mlz32641lbd8mc/" target="_blank" rel="noopener" class="site-navbar__link"><!--F#1-->Subscribe<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/magazine" class="site-navbar__link"><!--F#1-->Magazine<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/videos" class="site-navbar__link"><!--F#1-->Videos<!--F/--></a><!--F/--></li><!--F/--></ul><ul class="site-navbar__items site-navbar__items--tertiary"><!--F#1--><li class="site-navbar__item"><!--F#1--><a href="/search" class="site-navbar__link"><!--F#1--><span title="Search" class="marko-web-icon marko-web-icon--search"><svg xmlns="http://www.w3.org/2000/svg" width="16" height="16" viewBox="0 0 16 16"><path fill-rule="evenodd" d="M15.7 13.3l-3.81-3.83A5.93 5.93 0 0 0 13 6c0-3.31-2.69-6-6-6S1 2.69 1 6s2.69 6 6 6c1.3 0 2.48-.41 3.47-1.11l3.83 3.81c.19.2.45.3.7.3.25 0 .52-.09.7-.3a.996.996 0 0 0 0-1.41v.01zM7 10.7c-2.59 0-4.7-2.11-4.7-4.7 0-2.59 2.11-4.7 4.7-4.7 2.59 0 4.7 2.11 4.7 4.7 0 2.59-2.11 4.7-4.7 4.7z"/></svg></span><!--F/--></a><!--F/--></li><!--F/--></ul><!--F/--><!--F/--></div><!--F/--></nav><nav class="site-navbar site-navbar--primary"><!--F#1--><div class="site-navbar__container"><!--F#1--><!--F#2--><ul class="site-navbar__items site-navbar__items--primary"><!--F#1--><li class="site-navbar__item"><!--F#1--><a href="/associations" class="site-navbar__link"><!--F#1-->Associations<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/big-50" class="site-navbar__link"><!--F#1-->Big 50<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/business-technology" class="site-navbar__link"><!--F#1-->Business Technology<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/earnings" class="site-navbar__link"><!--F#1-->Earnings<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/economy" class="site-navbar__link"><!--F#1-->Economy<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/mergers-acquisitions" class="site-navbar__link"><!--F#1-->Mergers & Acquisitions<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/operations" class="site-navbar__link"><!--F#1-->Operations<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/sales" class="site-navbar__link"><!--F#1-->Sales<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/staffing-changes" class="site-navbar__link"><!--F#1-->Staffing Changes<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/supply-chain" class="site-navbar__link"><!--F#1-->Supply Chain<!--F/--></a><!--F/--></li><li class="site-navbar__item"><!--F#1--><a href="/workforce-development" class="site-navbar__link"><!--F#1-->Workforce<!--F/--></a><!--F/--></li><!--F/--></ul><!--F/--><!--F/--></div><!--F/--></nav><!--F/--></header><aside class="site-menu"><!--F#1--><div class="site-menu__contents"><!--F#1--><div class="site-menu__section"><!--F#1--><div class="site-menu__header"><!--F#1--><!--F#1-->Topics<!--F/--><!--F/--></div><ul class="site-menu__items"><!--F#1--><li class="site-menu__item"><!--F#1--><a href="/associations" class="site-menu__link"><!--F#1-->Associations<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/big-50" class="site-menu__link"><!--F#1-->Big 50<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/business-technology" class="site-menu__link"><!--F#1-->Business Technology<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/earnings" class="site-menu__link"><!--F#1-->Earnings<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/economy" class="site-menu__link"><!--F#1-->Economy<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/mergers-acquisitions" class="site-menu__link"><!--F#1-->Mergers & Acquisitions<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/operations" class="site-menu__link"><!--F#1-->Operations<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/sales" class="site-menu__link"><!--F#1-->Sales<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/staffing-changes" class="site-menu__link"><!--F#1-->Staffing Changes<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/supply-chain" class="site-menu__link"><!--F#1-->Supply Chain<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/workforce-development" class="site-menu__link"><!--F#1-->Workforce<!--F/--></a><!--F/--></li><!--F/--></ul><!--F/--></div><div class="site-menu__section"><!--F#1--><div class="site-menu__header"><!--F#1--><!--F#1-->Resources<!--F/--><!--F/--></div><ul class="site-menu__items"><!--F#1--><li class="site-menu__item"><!--F#1--><a href="/magazine" class="site-menu__link"><!--F#1-->Magazine<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/videos" class="site-menu__link"><!--F#1-->Videos<!--F/--></a><!--F/--></li><!--F/--></ul><!--F/--></div><div class="site-menu__section"><!--F#1--><div class="site-menu__header"><!--F#1--><!--F#1-->User Tools<!--F/--><!--F/--></div><ul class="site-menu__items"><!--F#1--><li class="site-menu__item"><!--F#1--><a href="https://ien.wufoo.com/forms/mlz32641lbd8mc/" target="_blank" rel="noopener" class="site-menu__link"><!--F#1-->Subscribe<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/page/id-advertising" class="site-menu__link"><!--F#1-->Advertising<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/page/id-about-us" class="site-menu__link"><!--F#1-->About Us<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/contact-us" class="site-menu__link"><!--F#1-->Contact Us<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/page/id-privacy-policy" class="site-menu__link"><!--F#1-->Privacy Policy<!--F/--></a><!--F/--></li><li class="site-menu__item"><!--F#1--><a href="/page/id-terms-conditions" class="site-menu__link"><!--F#1-->Terms & Conditions<!--F/--></a><!--F/--></li><!--F/--></ul><!--F/--></div><!--F/--></div><!--F/--></aside><!--F#17--><!--F#2--><!--F#1--><div id="div-gpt-ad-1576775627760-549"><script>googletag.cmd.push(function() { googletag.defineOutOfPageSlot('/137873098/INDT/default_wa', 'div-gpt-ad-1576775627760-549').addService(googletag.pubads()); googletag.display('div-gpt-ad-1576775627760-549'); });</script></div><div id="div-gpt-ad-1576775627760-495"><script>googletag.cmd.push(function() { googletag.defineOutOfPageSlot('/137873098/INDT/default_reskin', 'div-gpt-ad-1576775627760-495').addService(googletag.pubads()); googletag.display('div-gpt-ad-1576775627760-495'); });</script></div><!--F/--><!--F/--><!--F/--><!--F/--><div class="document-container"><article class="page page--content page--content-21107068 page--content-news"><!--F#1--><!--F#6--><div id="gpt-ad-lb1" class="ad-container ad-container--top-of-page"><script>googletag.cmd.push(function() { googletag.display('gpt-ad-lb1'); });</script></div><!--F#2--><!--F#1--><div class="page-wrapper"><div class="page-wrapper__section"><!--F#1--><div class="row"><div class="col"><nav class="breadcrumbs" aria-label="breadcrumb"><ol class="breadcrumb"><li class="breadcrumb-item"><!--F#3[0]--><a href="/" title="Home"><!--F#1-->Home<!--F/--></a><!--F/--></li><li class="breadcrumb-item"><!--F#3[1]--><a href="/awards" title="Awards"><!--F#1-->Awards<!--F/--></a><!--F/--></li></ol></nav><!--F#0--><h1 class="page-wrapper__title">RS Components Named Top Distributor & Educational Supporter at 2019 Elektra Awards</h1><!--F/--><!--F#0--><p class="page-wrapper__deck">The electrical distributor has been recognized for its support of programs like FIRST Lego League and the STEM teaching resources it provides for teachers.</p><!--F/--><div class="page-attribution"><!--F#1--><!--F#0--><!--F/--><!--F#0--><!--F/--><!--F/--></div><div class="page-dates"><!--F#1--><!--F#0--><div class="page-dates__content-published">Dec 18th, 2019</div><!--F/--><!--F/--></div></div></div><!--F/--></div><div class="page-wrapper__section"><!--F#1--><div class="row"><div class="page-contents col-lg-8 mb-3 mb-lg-0"><!--F#1--><div class="page-image page-image--fluid"><!--F#1--><div class="page-image__wrapper"><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/12/16x9/rs_logo.5dfa86b2c92a1.png?auto=format&amp;w=500" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/12/16x9/rs_logo.5dfa86b2c92a1.png?auto=format&amp;dpr=2&amp;w=500 2x" class="page-image__image lazyload" alt="Rs Logo"></div><!--F/--></div><div class="page-contact-details"><!--F#1--><!--F/--></div><!--F#0--><div class="page-contents__content-body"><p>FORT WORTH, TX —<b> </b><a href="http://icm-tracking.meltwater.com/link.php?DynEngagement=true&H=btYXC68syxmDVppbhVzFoYHdeMNV9070xvOlf%2FNdDQ0wXj6aidRhm0sg7Onq8c22wfwuV1JvA6DXci6e4XltYIXEPM67Q%2FZBYhNl6hSQRacoPtvYawSkPA%3D%3D&G=0&R=http%3A%2F%2Famericas.rsdelivers.com&I=20191216150048.00000ab7e9a4%40mail6-114-ussnn1&X=MHwxMDQ2NzU4OjVkZjNjMDYxYTM0NmMyNzhmNzA2NzFlZDs%3D&S=X0_csXkd7E4pX1SM5tHXKw8c5Z_BYQnkbGmb4FtWPyk" target="_blank" data-saferedirecturl="https://www.google.com/url?q=http://icm-tracking.meltwater.com/link.php?DynEngagement%3Dtrue%26H%3DbtYXC68syxmDVppbhVzFoYHdeMNV9070xvOlf%252FNdDQ0wXj6aidRhm0sg7Onq8c22wfwuV1JvA6DXci6e4XltYIXEPM67Q%252FZBYhNl6hSQRacoPtvYawSkPA%253D%253D%26G%3D0%26R%3Dhttp%253A%252F%252Famericas.rsdelivers.com%26I%3D20191216150048.00000ab7e9a4%2540mail6-114-ussnn1%26X%3DMHwxMDQ2NzU4OjVkZjNjMDYxYTM0NmMyNzhmNzA2NzFlZDs%253D%26S%3DX0_csXkd7E4pX1SM5tHXKw8c5Z_BYQnkbGmb4FtWPyk&source=gmail&ust=1576785609144000&usg=AFQjCNGqFZTBifreT31JCGo_5TdabgicnQ">RS Components</a> announced Dec. 16 that it has been recognized as the top distributor and supporter of educational efforts at the <a href="http://icm-tracking.meltwater.com/link.php?DynEngagement=true&H=btYXC68syxmDVppbhVzFoYHdeMNV9070xvOlf%2FNdDQ0wXj6aidRhm0sg7Onq8c22wfwuV1JvA6DXci6e4XltYIXEPM67Q%2FZBYhNl6hSQRacoPtvYawSkPA%3D%3D&G=0&R=https%3A%2F%2Fwww.elektraawards.co.uk%2Felektraawards2019%2Fen%2Fpage%2F2019-winners&I=20191216150048.00000ab7e9a4%40mail6-114-ussnn1&X=MHwxMDQ2NzU4OjVkZjNjMDYxYTM0NmMyNzhmNzA2NzFlZDs%3D&S=FIGc_llkqUUkt8VJb8kH5xjB87U71lV57ZzvYFo7ypk" target="_blank" data-saferedirecturl="https://www.google.com/url?q=http://icm-tracking.meltwater.com/link.php?DynEngagement%3Dtrue%26H%3DbtYXC68syxmDVppbhVzFoYHdeMNV9070xvOlf%252FNdDQ0wXj6aidRhm0sg7Onq8c22wfwuV1JvA6DXci6e4XltYIXEPM67Q%252FZBYhNl6hSQRacoPtvYawSkPA%253D%253D%26G%3D0%26R%3Dhttps%253A%252F%252Fwww.elektraawards.co.uk%252Felektraawards2019%252Fen%252Fpage%252F2019-winners%26I%3D20191216150048.00000ab7e9a4%2540mail6-114-ussnn1%26X%3DMHwxMDQ2NzU4OjVkZjNjMDYxYTM0NmMyNzhmNzA2NzFlZDs%253D%26S%3DFIGc_llkqUUkt8VJb8kH5xjB87U71lV57ZzvYFo7ypk&source=gmail&ust=1576785609144000&usg=AFQjCNFe5XlJSq-SFmCDuZtOdFvy9jltLQ">2019 Electronics Weekly Elektra Awards</a>.</p><p>For almost two decades the Elektra awards have highlighted exemplary efforts, products, and organizations across the global electronics industry. This year, RS Components earned Distributor of the Year Award for its all-around performance, as well as the Educational Supporter of the Year Award for its support of programs like FIRST Lego League and the <a href="http://icm-tracking.meltwater.com/link.php?DynEngagement=true&H=btYXC68syxmDVppbhVzFoYHdeMNV9070xvOlf%2FNdDQ0wXj6aidRhm0sg7Onq8c22wfwuV1JvA6DXci6e4XltYIXEPM67Q%2FZBYhNl6hSQRacoPtvYawSkPA%3D%3D&G=0&R=https%3A%2F%2Famericas.rsdelivers.com%2Fcampaigns%2Fstemimagine-x%2Fimagine-x&I=20191216150048.00000ab7e9a4%40mail6-114-ussnn1&X=MHwxMDQ2NzU4OjVkZjNjMDYxYTM0NmMyNzhmNzA2NzFlZDs%3D&S=hkQU8CkRlJYEu2zAjbdz06SY-H0qhZwCQIshTAxXwGU" target="_blank" data-saferedirecturl="https://www.google.com/url?q=http://icm-tracking.meltwater.com/link.php?DynEngagement%3Dtrue%26H%3DbtYXC68syxmDVppbhVzFoYHdeMNV9070xvOlf%252FNdDQ0wXj6aidRhm0sg7Onq8c22wfwuV1JvA6DXci6e4XltYIXEPM67Q%252FZBYhNl6hSQRacoPtvYawSkPA%253D%253D%26G%3D0%26R%3Dhttps%253A%252F%252Famericas.rsdelivers.com%252Fcampaigns%252Fstemimagine-x%252Fimagine-x%26I%3D20191216150048.00000ab7e9a4%2540mail6-114-ussnn1%26X%3DMHwxMDQ2NzU4OjVkZjNjMDYxYTM0NmMyNzhmNzA2NzFlZDs%253D%26S%3DhkQU8CkRlJYEu2zAjbdz06SY-H0qhZwCQIshTAxXwGU&source=gmail&ust=1576785609144000&usg=AFQjCNFl3CFVoSOrumxVmG5cto5zVuqpFw">STEM teaching resources</a> it provides for teachers.</p><p>“Providing the best experience for our customers and helping develop the next generation of engineers and scientists are both very important for RS Components,” said Fal Dieso, head of marketing for RS Components North America. “We are very excited to be among such an esteemed group of honorees.”</p><p><span data-embed-type="image" data-embed-id="5dfa86a8a30c222a008b4578" data-embed-align="right"><img class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/12/download.5dfa86a8640d9.png?auto=format&fit=max&w=1440" alt="Download"></span>RS Components is a trading brand of Electrocomponents plc. The company offers more than 500,000 industrial and electronic products sourced from over 2,500 suppliers and provides a wide range of value-added services to more than one million customers. With operations in 32 countries, RS Components ships more than 50,000 parcels a day.</p><p>RS Components supports customers across the product life cycle, whether via innovation and technical support at the design phase, improving time to market and productivity at the build phase, or reducing purchasing costs and optimizing inventory in the maintenance phase.</p></div><!--F/--><!--F/--></div><aside class="col-lg-4 page-rail"><!--F#2--><!--F#1--><!--F#2--><!--F#1--><!--F/--><!--F/--><!--F#2--><!--F#1--><!--F#1--><div class="node-list"><div class="node-list__header"><!--F#1--><!--F#1-->Latest in Awards<!--F/--><!--F/--></div><div class="node-list__nodes"><!--F#1--><div class="node-list__node"><!--F#1--><!--F#1--><!--F#3--><div class="node node--image-right node--flush node--news-content-type"><div class="node__contents"><!--F#1--><div style="width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-middle"><!--F#1--><a href="/awards/news/21107076/kimball-midwest-recognized-for-robust-training-programs" class="node__image-inner-wrapper"><!--F#1--><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/12/16x9/Kimball_Midwest_Logo.5dfa8942067ce.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/12/16x9/Kimball_Midwest_Logo.5dfa8942067ce.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="Kimball Midwest Logo"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/21107076/kimball-midwest-recognized-for-robust-training-programs"><!--F#1-->Kimball Midwest Recognized for Training Programs<!--F/--></a><!--F/--><!--F/--></h5><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><div><!--F#1[0]--><!--F#2--><!--F#1--><!--F#0--><div><a href="/awards/contact/21107073/kimball-midwest"><!--F#1-->Kimball Midwest<!--F/--></a></div><!--F/--><!--F/--><!--F/--><!--F/--></div><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Dec 18th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="node-list__node"><!--F#1--><!--F#1--><!--F#3--><div class="node node--image-right node--flush node--news-content-type"><div class="node__contents"><!--F#1--><div style="width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-middle"><!--F#1--><a href="/awards/news/21103637/weiler-abrasives-raises-100k-for-united-way" class="node__image-inner-wrapper"><!--F#1--><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Weiler_75.5ddeb4a984bf0.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Weiler_75.5ddeb4a984bf0.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="Weiler 75"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/21103637/weiler-abrasives-raises-100k-for-united-way"><!--F#1-->Weiler Abrasives Raises $100K for United Way<!--F/--></a><!--F/--><!--F/--></h5><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Nov 27th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="node-list__node"><!--F#1--><!--F#1--><!--F#3--><div class="node node--image-right node--flush node--news-content-type"><div class="node__contents"><!--F#1--><div style="width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-middle"><!--F#1--><a href="/awards/news/21103270/city-electric-supply-ceo-receives-ernst-young-2019-entrepreneur-of-the-year-award" class="node__image-inner-wrapper"><!--F#1--><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Rosenberg2.5ddc3e7804991.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Rosenberg2.5ddc3e7804991.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="Rosenberg2"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/21103270/city-electric-supply-ceo-receives-ernst-young-2019-entrepreneur-of-the-year-award"><!--F#1-->City Electric Supply CEO Receives Ernst & Young 2019 Entrepreneur Of The Year Award<!--F/--></a><!--F/--><!--F/--></h5><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Nov 25th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="node-list__node"><!--F#1--><!--F#1--><!--F#3--><div class="node node--image-right node--flush node--news-content-type"><div class="node__contents"><!--F#1--><div style="width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-middle"><!--F#1--><a href="/associations/news/21102988/iwdc-art-auction-raises-30000-for-workshops-for-warriors" class="node__image-inner-wrapper"><!--F#1--><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/IWDC_Logoa.jpg.5dd8316f2a4c2.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/IWDC_Logoa.jpg.5dd8316f2a4c2.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="Iwdc Logoa jpg"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Associations"><a href="/associations"><!--F#1-->Associations<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/associations/news/21102988/iwdc-art-auction-raises-30000-for-workshops-for-warriors"><!--F#1-->IWDC Art Auction Raises $30,000 for Workshops for Warriors<!--F/--></a><!--F/--><!--F/--></h5><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><div><!--F#1[0]--><!--F#2--><!--F#1--><!--F#0--><div><a href="/home/contact/21102989/iwdc"><!--F#1-->IWDC<!--F/--></a></div><!--F/--><!--F/--><!--F/--><!--F/--></div><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Nov 22nd, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="node-list__node"><!--F#1--><!--F#1--><!--F#3--><div class="node node--image-right node--flush node--news-content-type"><div class="node__contents"><!--F#1--><div style="width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-middle"><!--F#1--><a href="/awards/news/21102842/ads-fernandez-accepts-isas-wise-impact-award" class="node__image-inner-wrapper"><!--F#1--><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/4.5dd70c1521af1.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/4.5dd70c1521af1.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="4"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/21102842/ads-fernandez-accepts-isas-wise-impact-award"><!--F#1-->AD’s Fernandez accepts ISA's W.I.S.E. Impact Award<!--F/--></a><!--F/--><!--F/--></h5><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><div><!--F#1[0]--><!--F#2--><!--F#1--><!--F#0--><div><a href="/home/contact/21106322/affiliated-distributors-ad"><!--F#1-->Affiliated Distributors (AD)<!--F/--></a></div><!--F/--><!--F/--><!--F/--><!--F/--></div><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Nov 21st, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--><!--F/--><!--F/--><div id="gpt-ad-rail1" class="ad-container"><script>googletag.cmd.push(function() { googletag.display('gpt-ad-rail1'); });</script></div><div id="gpt-ad-rail2" class="ad-container"><script>googletag.cmd.push(function() { googletag.display('gpt-ad-rail2'); });</script></div></aside></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--><!--F/--></article><!--F#3--><div id="gpt-ad-billboard" class="ad-container ad-container--bottom-of-page"><script>googletag.cmd.push(function() { googletag.display('gpt-ad-billboard'); });</script></div><!--F#2--><!--F#1--><!--F#2--><!--F#1--><!--F#1--><section class="page page--load-more page--page-1 page--content page--content-21107068 page--content-news"><!--F#1--><div id="vue-1576775627852-309"><script>CMSBrowserComponents.loadComponent('#vue-1576775627852-309', 'TriggerInViewEvent', {"eventName":"load-more-in-view","data":{"page_number":2}});</script></div><div class="load-more-header">More in Awards</div><div class="card-deck-flow card-deck-flow--3-cols"><!--F#1--><div class="card-deck-flow__node"><!--F#1--><!--F#6[0]--><!--F#3--><div class="node node--image-top node--card node--full-height node--news-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/awards/news/21097605/grainger-donates-100k-to-folds-of-honor-doubling-commitment-to-military-families" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Graingera.5dcdd5331907a.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Graingera.5dcdd5331907a.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Graingera"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/21097605/grainger-donates-100k-to-folds-of-honor-doubling-commitment-to-military-families"><!--F#1-->Grainger Donates $100K to Folds of Honor, Doubling Commitment to Military Families<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/21097605/grainger-donates-100k-to-folds-of-honor-doubling-commitment-to-military-families"><!--F#1-->At twice the amount of Grainger's 2018, the donation will fund 20 STEM scholarships of $5,000 each to military families nationwide.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Nov 14th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="card-deck-flow__node"><!--F#1--><!--F#6[1]--><!--F#3--><div class="node node--image-top node--card node--full-height node--article-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/home/article/21095188/industrial-distributions-2019-big-50-list" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Thumb.5dc1ede6debab.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Thumb.5dc1ede6debab.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Thumb"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Home"><a href="/"><!--F#1-->Home<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/home/article/21095188/industrial-distributions-2019-big-50-list"><!--F#1-->Industrial Distribution's 2019 Big 50 List<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/home/article/21095188/industrial-distributions-2019-big-50-list"><!--F#1-->You've seen our 2019 Big 50 countdown videos (and if not, you really should). Here, see the ID's 2019 Big 50 List in a concise, easy-reference format.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><div><!--F#1[0]--><!--F#2--><!--F#1--><!--F#0--><div><a href="/home/contact/13115257/mike-hockett"><!--F#1-->Mike Hockett<!--F/--></a></div><!--F/--><!--F/--><!--F/--><!--F/--><!--F#1[1]--><!--F#2--><!--F#1--><!--F#0--><div><a href="/home/contact/13103171/anna-wells"><!--F#1-->Anna Wells<!--F/--></a></div><!--F/--><!--F/--><!--F/--><!--F/--></div><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Nov 11th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="card-deck-flow__node card-deck-flow__node--position-after"><!--F#1--><!--F#8[1]--><div id="div-gpt-ad-1576775627856-806" class="ad-container ad-container--in-card"><script>googletag.cmd.push(function() { googletag.defineSlot('/137873098/INDT/default_load-more', [300,250], 'div-gpt-ad-1576775627856-806').addService(googletag.pubads()); googletag.display('div-gpt-ad-1576775627856-806'); });</script></div><!--F/--><!--F/--></div><div class="card-deck-flow__node"><!--F#1--><!--F#6[2]--><!--F#3--><div class="node node--image-top node--card node--full-height node--news-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/awards/news/21096297/eriksowned-industrial-controls-rawson-to-host-2019-automation-controls-symposium" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/industrial_controls_logo.jpga.5dc3492c74bea.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/industrial_controls_logo.jpga.5dc3492c74bea.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Industrial Controls Logo jpga"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/21096297/eriksowned-industrial-controls-rawson-to-host-2019-automation-controls-symposium"><!--F#1-->ERIKS-Owned Industrial Controls, Rawson to Host 2019 Automation & Controls Symposium<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/21096297/eriksowned-industrial-controls-rawson-to-host-2019-automation-controls-symposium"><!--F#1-->Now in its eighth year, the Automation & Controls Symposium is a learning and networking event for professionals in the infrastructure, power plant, water, transportation, and building automation industries.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Nov 6th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="card-deck-flow__node"><!--F#1--><!--F#6[3]--><!--F#3--><div class="node node--image-top node--card node--full-height node--video-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/awards/video/21095771/industrial-distributions-2019-big-50-countdown-5031" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Thumb.5dc18e6f1343f.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/11/16x9/Thumb.5dc18e6f1343f.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Thumb"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/video/21095771/industrial-distributions-2019-big-50-countdown-5031"><!--F#1-->Industrial Distribution's 2019 Big 50 Countdown: 50-31<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/video/21095771/industrial-distributions-2019-big-50-countdown-5031"><!--F#1-->Presented by editors Anna Wells and Mike Hockett, see the first part of ID's 2019 Big 50 List video countdown, covering companies from No. 50 through 31.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><div><!--F#1[0]--><!--F#2--><!--F#1--><!--F#0--><div><a href="/home/contact/21095774/alex-shanahan"><!--F#1-->Alex Shanahan<!--F/--></a></div><!--F/--><!--F/--><!--F/--><!--F/--><!--F#1[1]--><!--F#2--><!--F#1--><!--F#0--><div><a href="/home/contact/21094765/eric-sorensen"><!--F#1-->Eric Sorensen<!--F/--></a></div><!--F/--><!--F/--><!--F/--><!--F/--><!--F#1[2]--><!--F#2--><!--F#1--><!--F#0--><div><a href="/home/contact/13115257/mike-hockett"><!--F#1-->Mike Hockett<!--F/--></a></div><!--F/--><!--F/--><!--F/--><!--F/--><!--F#1[3]--><!--F#2--><!--F#1--><!--F#0--><div><a href="/home/contact/13103171/anna-wells"><!--F#1-->Anna Wells<!--F/--></a></div><!--F/--><!--F/--><!--F/--><!--F/--></div><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Nov 5th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="card-deck-flow__node"><!--F#1--><!--F#6[4]--><!--F#3--><div class="node node--image-top node--card node--full-height node--news-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/awards/news/21094971/sandy-sullivan-receives-ptda-foundations-2019-wendy-b-mcdonald-award" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/10/16x9/asdf.5db9e77fa7157.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/10/16x9/asdf.5db9e77fa7157.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Sandy Sullivan delivering her Wendy B. McDonald Award acceptance speech during the PTDA Industry Summit Oct. 25 in Austin, TX."><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/21094971/sandy-sullivan-receives-ptda-foundations-2019-wendy-b-mcdonald-award"><!--F#1-->Sandy Sullivan Receives PTDA Foundation’s 2019 Wendy B. McDonald Award<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/21094971/sandy-sullivan-receives-ptda-foundations-2019-wendy-b-mcdonald-award"><!--F#1-->Sullivan has been with Nidec Motor Corp. since 2003 and is currently its national account director, along with PTDA's Manufacturing Council Chair.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Oct 30th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="card-deck-flow__node"><!--F#1--><!--F#6[5]--><!--F#3--><div class="node node--image-top node--card node--full-height node--news-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/associations/news/21093546/netplus-alliance-recognizes-award-winners-at-annual-meeting" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/10/16x9/Distributor_of_the_Year_Northern_Safety_and_Industrial_small.5daf5ad4d8a6d.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/10/16x9/Distributor_of_the_Year_Northern_Safety_and_Industrial_small.5daf5ad4d8a6d.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Members of Northern Safety &amp;amp; Industrial posing with NetPlus Alliance executives after accepting NetPlus&amp;apos; Distributor of the Year Award."><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Associations"><a href="/associations"><!--F#1-->Associations<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/associations/news/21093546/netplus-alliance-recognizes-award-winners-at-annual-meeting"><!--F#1-->NetPlus Alliance Recognizes Award Winners<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/associations/news/21093546/netplus-alliance-recognizes-award-winners-at-annual-meeting"><!--F#1-->NetPlus Alliance hosted 500 distributor and supplier attendees at its sixth-annual meeting Oct. 5-8 in Dallas, TX. See who took home its annual awards.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Oct 22nd, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="card-deck-flow__node"><!--F#1--><!--F#6[6]--><!--F#3--><div class="node node--image-top node--card node--full-height node--news-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/awards/news/13777839/winner-of-2019-bsa-lifetime-achievement-award-announced" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/06/id_40628_bsa_logo_edit.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/06/id_40628_bsa_logo_edit.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Id 40628 Bsa Logo Edit"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/13777839/winner-of-2019-bsa-lifetime-achievement-award-announced"><!--F#1-->Winner of 2019 BSA Lifetime Achievement Award Announced<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/13777839/winner-of-2019-bsa-lifetime-achievement-award-announced"><!--F#1-->Linda Miller, vice president of IT, was named recipient of the 2019 BSA Lifetime Achievement Award.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Jun 10th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="card-deck-flow__node card-deck-flow__node--position-after"><!--F#1--><!--F#8[6]--><div id="div-gpt-ad-1576775627864-302" class="ad-container ad-container--in-card"><script>googletag.cmd.push(function() { googletag.defineSlot('/137873098/INDT/default_load-more', [300,250], 'div-gpt-ad-1576775627864-302').addService(googletag.pubads()); googletag.display('div-gpt-ad-1576775627864-302'); });</script></div><!--F/--><!--F/--></div><div class="card-deck-flow__node"><!--F#1--><!--F#6[7]--><!--F#3--><div class="node node--image-top node--card node--full-height node--news-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/awards/news/13777817/kinnunen-salute-to-the-skilled-workforce-award-winner-announced" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/06/id_40508_dylan_cates_2_1_.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/06/id_40508_dylan_cates_2_1_.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Id 40508 Dylan Cates 2 1"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/13777817/kinnunen-salute-to-the-skilled-workforce-award-winner-announced"><!--F#1-->Kinnunen Salute to the Skilled Workforce Award Winner Announced<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/13777817/kinnunen-salute-to-the-skilled-workforce-award-winner-announced"><!--F#1-->Dylan Cates is the recipient of this year’s Salute to the Skilled Workforce award from Kinnunen Sales and Rental.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Jun 4th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="card-deck-flow__node"><!--F#1--><!--F#6[8]--><!--F#3--><div class="node node--image-top node--card node--full-height node--news-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/awards/news/13777778/kimball-midwest-earns-top-workplaces-award" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/05/id_40328_kimble_midwest.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/05/id_40328_kimble_midwest.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Id 40328 Kimble Midwest"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/13777778/kimball-midwest-earns-top-workplaces-award"><!--F#1-->Kimball Midwest Earns Top Workplaces Award<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/13777778/kimball-midwest-earns-top-workplaces-award"><!--F#1-->It is the seventh consecutive year the company has received the honor from Columbus CEO magazine.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>May 29th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="card-deck-flow__node"><!--F#1--><!--F#6[9]--><!--F#3--><div class="node node--image-top node--card node--full-height node--news-content-type"><div class="node__contents"><!--F#1--><div class="node__image-wrapper"><!--F#1--><a href="/awards/news/13777752/tti-receives-molex-2018-global-distributor-of-the-year-award" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-21by9"><!--F#1--><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/05/id_40184_tti_logo.png?auto=format&amp;fit=crop&amp;h=146&amp;w=340" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/05/id_40184_tti_logo.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=146&amp;w=340 2x" class="node__image lazyload" alt="Id 40184 Tti Logo"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/13777752/tti-receives-molex-2018-global-distributor-of-the-year-award"><!--F#1-->TTI Receives Molex 2018 Global Distributor of the Year Award<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/13777752/tti-receives-molex-2018-global-distributor-of-the-year-award"><!--F#1-->This award recognizes one outstanding global channel partner each year for advancing Molex technology solutions through demonstrated growth in worldwide sales.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>May 21st, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><!--F/--></div><div class="column-list-flow"><!--F#1--><div class="column-list-flow__column"><!--F#1--><!--F#2--><div id="div-gpt-ad-1576775627868-240" class="ad-container ad-container--in-card"><script>googletag.cmd.push(function() { googletag.defineSlot('/137873098/INDT/default_load-more', [300,600], 'div-gpt-ad-1576775627868-240').addService(googletag.pubads()); googletag.display('div-gpt-ad-1576775627868-240'); });</script></div><!--F/--><!--F/--></div><div class="column-list-flow__list"><!--F#1--><!--F#4--><div class="node-list node-list--inner-justified"><div class="node-list__nodes"><!--F#1--><div class="node-list__node"><!--F#1--><!--F#1--><!--F#3--><div class="node node--image-right node--flush node--news-content-type"><div class="node__contents"><!--F#1--><div style="width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-middle"><!--F#1--><a href="/awards/news/13777733/mouser-electronics-named-distributor-of-the-year-by-littelfuse" class="node__image-inner-wrapper"><!--F#1--><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/05/id_40097_018_high_service_distributor_of_the_year_award.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/05/id_40097_018_high_service_distributor_of_the_year_award.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="Id 40097 018 High Service Distributor Of The Year Award"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/13777733/mouser-electronics-named-distributor-of-the-year-by-littelfuse"><!--F#1-->Mouser Electronics Named Distributor of the Year by Littelfuse<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/13777733/mouser-electronics-named-distributor-of-the-year-by-littelfuse"><!--F#1-->Mouser Electronics, Inc. has been recognized as the 2018 High Service Distributor of the Year by Littelfuse.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>May 16th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="node-list__node"><!--F#1--><!--F#1--><!--F#3--><div class="node node--image-right node--flush node--news-content-type"><div class="node__contents"><!--F#1--><div style="width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-middle"><!--F#1--><a href="/awards/news/13777678/msc-industrial-supply-co-names-stanley-black-decker-supplier-of-the-year" class="node__image-inner-wrapper"><!--F#1--><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/04/id_39551_stanley_black_and_decker_logo_edit.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/04/id_39551_stanley_black_and_decker_logo_edit.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="Id 39551 Stanley Black And Decker Logo Edit"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/13777678/msc-industrial-supply-co-names-stanley-black-decker-supplier-of-the-year"><!--F#1-->MSC Industrial Supply Co. Names Stanley Black & Decker 'Supplier of the Year'<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/13777678/msc-industrial-supply-co-names-stanley-black-decker-supplier-of-the-year"><!--F#1-->MSC Industrial Supply Co. has named Stanley Black & Decker its 'Supplier of the Year.'<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>May 6th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="node-list__node"><!--F#1--><!--F#1--><!--F#3--><div class="node node--image-right node--flush node--news-content-type"><div class="node__contents"><!--F#1--><div style="width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-middle"><!--F#1--><a href="/awards/news/13777641/distributor-hartman-independent-company-wins-2019-family-business-awards" class="node__image-inner-wrapper"><!--F#1--><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/04/id_39632_hartman_logo_edit.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/04/id_39632_hartman_logo_edit.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="Id 39632 Hartman Logo Edit"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/13777641/distributor-hartman-independent-company-wins-2019-family-business-awards"><!--F#1-->Distributor Hartman Independent Company Wins 2019 Family Business Awards<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/13777641/distributor-hartman-independent-company-wins-2019-family-business-awards"><!--F#1-->The 2019 Family Business Award presented annually by the Pittsburgh Business Times.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Apr 30th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><div class="node-list__node"><!--F#1--><!--F#1--><!--F#3--><div class="node node--image-right node--flush node--news-content-type"><div class="node__contents"><!--F#1--><div style="width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-middle"><!--F#1--><a href="/awards/news/13777584/all-industrial-tool-supply-president-jeff-perry-selected-as-2019-california-small-business-person-of-the-year" class="node__image-inner-wrapper"><!--F#1--><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.inddist.com/files/base/indm/all/image/2019/04/id_39341_all_industrial_tool_logo_edit.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.inddist.com/files/base/indm/all/image/2019/04/id_39341_all_industrial_tool_logo_edit.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="Id 39341 All Industrial Tool Logo Edit"><!--F/--></a><!--F/--></div><div class="node__body"><!--F#1--><div class="node__header node__header--body node__header--"><!--F#1--><div class="node__header-left"><!--F#1--><!--F#0--><div title="Awards"><a href="/awards"><!--F#1-->Awards<!--F/--></a></div><!--F/--><!--F/--></div><!--F/--></div><div class="node__contents node__contents--body"><!--F#1--><h5 class="node__title"><!--F#1--><!--F#0--><a href="/awards/news/13777584/all-industrial-tool-supply-president-jeff-perry-selected-as-2019-california-small-business-person-of-the-year"><!--F#1-->All Industrial Tool Supply President Jeff Perry Selected as 2019 California Small Business Person of the Year<!--F/--></a><!--F/--><!--F/--></h5><div class="node__text node__text--teaser"><!--F#1--><!--F#0--><a href="/awards/news/13777584/all-industrial-tool-supply-president-jeff-perry-selected-as-2019-california-small-business-person-of-the-year"><!--F#1-->All Industrial Tool Supply is a full-service distributor of metalworking tools and industrial supplies headquartered in Huntington Beach, California.<!--F/--></a><!--F/--><!--F/--></div><!--F/--></div><div class="node__footer node__footer--body node__footer--"><!--F#1--><div class="node__footer-left"><!--F#1--><!--F#0--><!--F/--><!--F/--></div><div class="node__footer-right"><!--F#1--><!--F#0--><div>Apr 17th, 2019</div><!--F/--><!--F/--></div><!--F/--></div><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--><!--F/--></div><!--F/--></div></div><!--F/--><!--F/--></div><!--F/--></div><div id="vue-1576775627874-99"><script>CMSBrowserComponents.loadComponent('#vue-1576775627874-99', 'LoadMoreTrigger', {"appendTo":".document-container","pageNumber":1,"provide":{"header":"More in Awards","componentName":"content-load-more-flow","componentInput":{"aliases":["awards"]},"fragmentName":"content-list","queryName":"website-scheduled-content","queryParams":{"sectionId":63212,"excludeContentIds":[21107068],"limit":14,"queryName":"LoadMore","after":"MTM3Nzc1ODQ"},"pageInput":{"for":"content","id":21107068,"type":"news"}},"show":true,"mountPoint":"/__load-more"});</script></div><!--F/--></section><!--F/--><!--F/--><!--F/--><!--F/--><!--F/--><!--F/--></div><!--F#11--><footer class="site-footer"><!--F#1--><div class="site-footer__container site-footer__container--secondary"><!--F#1--><!--F#1--><a href="/" class="site-footer__brand"><!--F#1--><!--F#1--><img class="site-footer__logo lazyload" alt="Industrial Distribution" src="https://base.imgix.net/files/base/indm/id/static/id_logo.png?h=60" srcset="https://base.imgix.net/files/base/indm/id/static/id_logo.png?h=120 2x"><!--F/--><!--F/--></a><!--F/--><!--F/--></div><div class="site-footer__container site-footer__container--primary"><!--F#1--><!--F#1--><div class="site-footer__social-icons"><!--F#1--><a href="http://www.facebook.com/pages/Industrial-Distribution/111265965577111" title="Visit us on Facebook" class="social-icon-link"><!--F#1--><span class="marko-web-icon marko-web-icon--light marko-web-icon--xl marko-web-icon--shadow marko-web-icon--facebook"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Facebook icon</title><path d="M23.9981 11.9991C23.9981 5.37216 18.626 0 11.9991 0C5.37216 0 0 5.37216 0 11.9991C0 17.9882 4.38789 22.9522 10.1242 23.8524V15.4676H7.07758V11.9991H10.1242V9.35553C10.1242 6.34826 11.9156 4.68714 14.6564 4.68714C15.9692 4.68714 17.3424 4.92149 17.3424 4.92149V7.87439H15.8294C14.3388 7.87439 13.8739 8.79933 13.8739 9.74824V11.9991H17.2018L16.6698 15.4676H13.8739V23.8524C19.6103 22.9522 23.9981 17.9882 23.9981 11.9991Z"/></svg></span><!--F/--></a><a href="https://www.linkedin.com/groups/3338596" title="Visit us on Linkedin" class="social-icon-link"><!--F#1--><span class="marko-web-icon marko-web-icon--light marko-web-icon--xl marko-web-icon--shadow marko-web-icon--linkedin"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>LinkedIn icon</title><path d="M20.447 20.452h-3.554v-5.569c0-1.328-.027-3.037-1.852-3.037-1.853 0-2.136 1.445-2.136 2.939v5.667H9.351V9h3.414v1.561h.046c.477-.9 1.637-1.85 3.37-1.85 3.601 0 4.267 2.37 4.267 5.455v6.286zM5.337 7.433c-1.144 0-2.063-.926-2.063-2.065 0-1.138.92-2.063 2.063-2.063 1.14 0 2.064.925 2.064 2.063 0 1.139-.925 2.065-2.064 2.065zm1.782 13.019H3.555V9h3.564v11.452zM22.225 0H1.771C.792 0 0 .774 0 1.729v20.542C0 23.227.792 24 1.771 24h20.451C23.2 24 24 23.227 24 22.271V1.729C24 .774 23.2 0 22.222 0h.003z"/></svg></span><!--F/--></a><a href="http://www.twitter.com/indistwebsite" title="Visit us on Twitter" class="social-icon-link"><!--F#1--><span class="marko-web-icon marko-web-icon--light marko-web-icon--xl marko-web-icon--shadow marko-web-icon--twitter"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Twitter icon</title><path d="M23.954 4.569c-.885.389-1.83.654-2.825.775 1.014-.611 1.794-1.574 2.163-2.723-.951.555-2.005.959-3.127 1.184-.896-.959-2.173-1.559-3.591-1.559-2.717 0-4.92 2.203-4.92 4.917 0 .39.045.765.127 1.124C7.691 8.094 4.066 6.13 1.64 3.161c-.427.722-.666 1.561-.666 2.475 0 1.71.87 3.213 2.188 4.096-.807-.026-1.566-.248-2.228-.616v.061c0 2.385 1.693 4.374 3.946 4.827-.413.111-.849.171-1.296.171-.314 0-.615-.03-.916-.086.631 1.953 2.445 3.377 4.604 3.417-1.68 1.319-3.809 2.105-6.102 2.105-.39 0-.779-.023-1.17-.067 2.189 1.394 4.768 2.209 7.557 2.209 9.054 0 13.999-7.496 13.999-13.986 0-.209 0-.42-.015-.63.961-.689 1.8-1.56 2.46-2.548l-.047-.02z"/></svg></span><!--F/--></a><a href="https://www.youtube.com/user/InDistribution" title="Visit us on Youtube" class="social-icon-link"><!--F#1--><span class="marko-web-icon marko-web-icon--light marko-web-icon--xl marko-web-icon--shadow marko-web-icon--youtube"><svg role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>YouTube icon</title><path d="M23.495 6.205a3.007 3.007 0 0 0-2.088-2.088c-1.87-.501-9.396-.501-9.396-.501s-7.507-.01-9.396.501A3.007 3.007 0 0 0 .527 6.205a31.247 31.247 0 0 0-.522 5.805 31.247 31.247 0 0 0 .522 5.783 3.007 3.007 0 0 0 2.088 2.088c1.868.502 9.396.502 9.396.502s7.506 0 9.396-.502a3.007 3.007 0 0 0 2.088-2.088 31.247 31.247 0 0 0 .5-5.783 31.247 31.247 0 0 0-.5-5.805zM9.609 15.601V8.408l6.264 3.602z"/></svg></span><!--F/--></a><!--F/--></div><ul class="site-footer__items"><!--F#1--><li class="site-footer__item"><!--F#1--><a href="/page/id-about-us" class="site-footer__link"><!--F#1-->About Us<!--F/--></a><!--F/--></li><li class="site-footer__item"><!--F#1--><a href="/page/id-advertising" class="site-footer__link"><!--F#1-->Advertising<!--F/--></a><!--F/--></li><li class="site-footer__item"><!--F#1--><a href="/contact-us" class="site-footer__link"><!--F#1-->Contact Us<!--F/--></a><!--F/--></li><li class="site-footer__item"><!--F#1--><a href="/page/id-privacy-policy" class="site-footer__link"><!--F#1-->Privacy Policy<!--F/--></a><!--F/--></li><li class="site-footer__item"><!--F#1--><a href="/page/id-terms-conditions" class="site-footer__link"><!--F#1-->Terms & Conditions<!--F/--></a><!--F/--></li><!--F/--></ul><div class="site-footer__copyright"><!--F#1-->&copy; 2019 Industrial Media, LLC. All rights reserved.<!--F/--></div><!--F/--><!--F/--></div><!--F/--></footer><!--F/--><!--F#13--><!--F#2--><!--F#1--><div id="vue-1576775627767-576"><script>CMSBrowserComponents.loadComponent('#vue-1576775627767-576', 'GAMFixedAdBottom', {"id":"div-gpt-ad-1576775627767-176","path":"/137873098/INDT/default_lb2","size":[[970,90],[970,66],[728,90],[320,50],[300,50],[300,100]],"sizeMapping":[{"viewport":[980,0],"size":[[970,90],[970,66],[728,90]]},{"viewport":[750,0],"size":[728,90]},{"viewport":[320,0],"size":[[300,50],[320,50],[300,100]]}],"refreshInterval":0});</script></div><!--F/--><!--F/--><!--F/--><script>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</script></body></html><!--M/-->